Oozing Goo - The Lava Lamp Syndicate

I bought a lava lamp off of eBay & it arrived today. The water is clear ( blue ) but the purple lava is full of lots of white particles.............. Is there something wrong with it - my other lamps aren't like this - do you think I should return it?
Any help appreciated :-)

Views: 472

Reply to This

Replies to This Discussion

ive heard that lava lamps don't always travel very well & that this can cause the all white bits in the wax. It can also happen when they get older but as yours is a brand new lamp, my guess would be the travelling - especially from UK to USA.
When Mathmos first released their turquoise Astro lots of them were cloudy with specks in them. I have had mine for years now and after the first couple of weeks the specks and the cloudiness cleared up. I would keep running it. It is actually quite amazing the amount of problems clear up with general use.
I bought a Mathmos Astro off gumtree yesterday and have rejuvenated it, it also had lost of scummy white crud, it is there when cold and static but disappears while cycling.

I'm on my second rejuvenation already. I was happy with how it was flowing but wanted to take a more calculated path to making good, and I added colour to the water and didn't like it!
It started like the first image,
Was like the second image after a night of fiddling
And is now like the third image.
I am yet to add any washing up liquid yet, I am working on adding the right amount of Epsom salts solution. So far 50ml of salts solution added, think it's spot on.

Paul.
Attachments:

Reply to Discussion

RSS

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2018   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service