Oozing Goo - The Lava Lamp Syndicate

Hey all!

I got my second imported Mathmos, a beautiful copper/black Telstar with Green/Blue bottle. I'm using a converter for the wattage. This is probably the 5th or 6th time I'm running it and it flows...just really slowly. Like, it'll shoot up a big blob like in the image, usually one at a time and very slowly. Could it just need more time to break in? 

We're having some warmer days here so it is operating at a higher ambient temp than recommended (around 78 in the apartment), and while I'd be inclined to think MAYBE it's overheating, it hasn't behaved much different on cooler days and my wall neos seem to be flowing beautifully. 

Anyone have similar flow with their newer Telstars? 

Views: 90

Reply to This

Replies to This Discussion

No overheating. Probably too low lamp temp.

Interesting... Another collector just got his imported to the US as well and said he was convinced that the 28W bulb wasn't strong enough, I wonder if that's the case with mine, given that I'm operating it in a room that's at least 25-26C most of the time. 

Zapiao said:

No overheating. Probably too low lamp temp.

Mine in summer operates at +30ºC and flows very well. You know when is overheating because it will make many bubles flowing.

that stretchy flow is what craven walker did, unlike just blobs, if the coil isnt covered and the wax is going up just on one side of it  then id say its to hot as in the wax isnt making contact with all of the coil.

But if it is and youre getting the stretchy flow like that then it comes down and starts up again id say its how the flow is. most of mathmos's flows now are just blobs not nice stretching to the top flow and breaking off 

Huh! I had seen some people complaining that the mathmos don't flow like the original crestworths did. Here's a timelapse of it going recently btw: https://www.reddit.com/r/Lavalamps/comments/h7xv44/my_new_telstar_s...

Johnny said:

that stretchy flow is what craven walker did, unlike just blobs, if the coil isnt covered and the wax is going up just on one side of it  then id say its to hot as in the wax isnt making contact with all of the coil.

But if it is and youre getting the stretchy flow like that then it comes down and starts up again id say its how the flow is. most of mathmos's flows now are just blobs not nice stretching to the top flow and breaking off 

the pic in your link looks like its a good flow to be honest 

Reply to Discussion

RSS

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2020   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service