Oozing Goo - The Lava Lamp Syndicate

So, this happened. Turns out you can't run a 40W bulb in a Gemlite with a plastic base. And, I only noticed this when I had picked this up from the floor after knocking it off the shelf. :-/

Views: 167

Comment

You need to be a member of Oozing Goo - The Lava Lamp Syndicate to add comments!

Join Oozing Goo - The Lava Lamp Syndicate

Comment by Erin on April 11, 2012 at 12:51pm

Balls. :( Too late now...

Comment by Dr. WHAT?! on April 11, 2012 at 12:49pm

Both of mine use a 25 w and they run hot on those.

http://oozinggoo.ning.com/photo/mystiques-1?context=user

Comment by Erin on April 11, 2012 at 12:45pm

But it was a lava lamp, not a glitter lamp. :( Either way, it's toast now. I need to make another base... (it needed the top, too, anyway). 

Comment by Dr. WHAT?! on April 11, 2012 at 12:42pm

oh wow wait, I just saw this, you had a 40 watt on it?!?!?! Erin! naughty!

Comment by Dr. WHAT?! on April 11, 2012 at 12:42pm

That's sucks Erin :( mine are pretty warped too, but not this bad. One thing I did with my lava version is bunched up of tinfoil under the bulb so the plastic part would have less heat on it when running. My other glitter one has a deflector ring on it so if your missing yours this could be the cause of the grilled cheese bottom :(

Comment by Erin on April 11, 2012 at 8:08am

I am now going to have to fashion a new base. Cap was missing too. Poop.

Comment by mr_a500 on April 11, 2012 at 8:05am

This wouldn't have happened with Bakelite.

Comment by Erin on April 11, 2012 at 7:54am

Son, I am disappoint.

Comment by Erin on April 11, 2012 at 7:54am

It's the bottom of the lava lamp pictured here: http://oozinggoo.ning.com/photo/gemlite-mystiques-one-lava-one-glit...

About

Mark Goo created this Ning Network.

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2022   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service