Oozing Goo - The Lava Lamp Syndicate

Have just unpacked my new Mathmos Telstar lamp that arrived today and im very disapointed, not with the lamp itself thats all fine but it doesnt have a UK mains plug fitted but a two prong euro one! Im sure its a genuine mistake but until Mathmos confirm back to me that cutting off and replacing the plug wont affect the warranty i cant run the lamp :( and this is their most expensive lava lamp too! Very disapointed!

Views: 17

Comment

You need to be a member of Oozing Goo - The Lava Lamp Syndicate to add comments!

Join Oozing Goo - The Lava Lamp Syndicate

Comment by Danial Thomas on November 8, 2009 at 1:57pm
Alls well that ends well, the Telstar is now up and running and looking great, the flow of the bottle is amazing, so different to any of my other lamps. Really pleased with it and worth every penny!
Comment by Danial Thomas on November 4, 2009 at 6:23am
Hey CL, yeh i can see the reasons for not cutting it off, im really pleased with the lamp tho and cant wait to get it running to see what the blue/green combo is like and its all new and shiny :) I thought maybe Mathmos has bases made for the euro market with two prong plugs and bases for the uk with uk plugs if i'd known they didnt i would have just fitted a new plug. I'll make sure i fit a good plug tho ;) I'll get some pix of the lamp up soon as ive got it running :)
Comment by Danial Thomas on November 4, 2009 at 3:13am
Hey Weebo, I can see what your saying and Mathmos have apologised and are sending me out a euro converter plug for it, it was just a mistake and i can understand that. But i really dont like these euro converters, they look ugly and are bulky to look at and as the plugs going to be on show its gotta come off. Im being picky i know but i just really hate them lol!
Comment by WeeboTech on November 3, 2009 at 8:28pm
I wouldn't cut it, some day you may choose to trade it. I would suggest keeping it as original as possible. I know you say, you would not trade it. I thought the same thing, yet years later here I am trading stuff away.
Comment by Danial Thomas on November 2, 2009 at 6:46pm
Yuck! I hate those plugs, if it did have one id have cut it off anyway lol! I have emailed them so will see what they say :)
Comment by Paul on November 2, 2009 at 4:46pm
The first telstar I had was fitted with a euro plug.

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2020   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service