Oozing Goo - The Lava Lamp Syndicate

So. . . I was going through some boxes about a month ago, and found my old lava lamp from when I was like. . . 11/12. (I'm 24 now.) After doing some research I found out that Hot Rock was a model produced by Creative Motion (if I'm looking in the right places.) I have no idea how to identify the age on this lamp, as there are absolutely no dates anywhere on the dang thing, but I know it's at least 12/13 years old. However, that's not even my issue at the moment.

After finding the lamp I just stuck it in a corner in the bedroom because I had some other, more important things, to worry about. Anyway, about two days ago I decided to plug it in and see if it worked. The last thing I remember about the lamp, the last time I tried using it, the wax didn't flow right. Well. . . The wax flows okay, and the water was only a tiny bit cloudy, which I figured was due to how old the lamp is. Great. However.

After having it cycle for two days now, it appears as if the chemical of whatever is in the lava has just about 85% bled out into the water, making the water VERY cloudy and the wax has taken on a transparency from losing whatever it is that made it opaque.

Also, The wax itself doesn't seem to blob in any other way other than mostly golf ball sized drops, along with a few smaller ones, and isn't as globby as it use to be when I was a kid. (I was a typical child and shook the thing, quite often, but it's always worked even after that.) It does have some issues sticking back together at the top and the bottom, kinda sitting there in little balls at either end, so I'm not sure if it's a heating issue or not, and I'm currently using what I believe is the same exact bulb that came with the lamp, a 40w clear reflective.

So here's my question:
Do I continue to cycle the lamp and see if the cloudiness goes back into the wax? Or is it shot and I should just replace the water in it? Filtering is out of the question because I cannot, and will not buy a filter for almost/over $100 just for one use. This is the only lamp I have and right now, taking on other lamps as a hobby (which I want to do) is just out of the question given I have a newborn and income is tight as it is. I'm not concerned too much at the consistency of the wax, given it mostly flows properly.

Any comments/advice/suggestions would be helpful. I will include pictures. Thank you!

Views: 2514

Attachments:

Reply to This

Replies to This Discussion

Evaporation.  An improper seal can cause water evaporated from the bottle to collect under the decorative cover and then run down the outside of the globe.

Reply to Discussion

RSS

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2021   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service