Oozing Goo - The Lava Lamp Syndicate

My review of Lava Lite's new "Designer" 32 oz. lamp

Received my new 32 oz. "Designer" lamp from LL today. Shipping was fast and item was packed well. Customer service was good - I had to cancel and re-order to apply a discount. No problems there. 

 

Globe color: clear/redNumbers on lamp: H4200, 11032401 D (date assembled must be March 24th, 2011). Cap has white and red sticker. 


Price paid: $34 shipped (with 10% discount)


The globe, much to my disappointment, was slightly cloudy. However, it was warm today and I really do expect that it might clear up. The clouding isn't as horrible as some I've seen, for sure. What's a little unsettling (pun intended?) is the fuzzies floating around in globe.

 
Upon first run, I can see some of these little floaties moving around in the liquid. 


 The finish is fairly cheap-feeling, but OK. Nice to see something new, I guess. I haven't owned any of the 20 oz. globes, but Autumn tells me the finish looks to be the same. The holes arount the base are a nice touch, but are a tad higher than the image sown on Lava Lite's website. 


My verdict for now? Don't buy (yet).

 

Rating as of right now: 6


I am running the lamp now for the first time. Updates to follow.

 

VIDEO of said floaties: http://www.youtube.com/watch?v=sPQyBXKaqVM 

Day two: http://www.youtube.com/watch?v=oSlLvW0MGBk 

 

Views: 2349

Reply to This

Replies to This Discussion

The clouding does look minimal. My fluidiums came just as cloudy so maybe the lamp will clear up.

I really hope it does. Right now, my big problem is with all the stuff floating around in the globe. It's pretty awful to look at. 

 

Video posted in original post.  

Also, the dots across the bottom aren't even spaced. Nitpicky, yes, I know, but still...

The lamp is now flowing, but still cloudy. Fuzz is floating around in the globe. I'll keep updating as the days go by.
Wait till summer is over for shipping lamps arrive cloudy in summer i think. The white bits when away for me after a few runs. It has a goose egg flow in the video.

They are not white bits, they look like dust. They are not in the lava, they are floating freely in the liquid. And yes, I do find myself focusing more on those than anything else Art!

 

I'm giving it a few more runs, then I'll ask for another or return it. Very disappointing. I really think you should open up a new lava lamp and be delighted. Opening this one up was disappointing and has been so the entire first day of ownership. I looked at it this morning, then glanced over at my beautiful 90s Century...there's just no comparison. *sigh*

 

I have a lot of other thoughts I'd like to post at this time, but I'm going to give this lamp a few more days. Sadly, I feel these problems won't go away. I intend to post on LL's Facebook page, but for once, I'd like to have an OPEN and PUBLIC conversation instead of them just posting "please contact us at blah blah". I want everyone to know. That being said, I feel bad for the people who work at LL - they just need jobs like we all do. It's not their fault their lamps are sub-par. I don't want to take my frustrations out on them, so I'm going to be careful with my words.

I wanna see pics of it flowing!  Has it overheated? I'm getting mine today so I want to see if I get the same issues as you.
I'll post pics of it flowing tonight. It didn't get going until about 2.5 hours in. It has that China flow...bigger blobs. Shawn, I am excited to hear about yours and see if you have the same issues as me. Keep me posted! Good luck.
Try putting the Globe in the Sun.
The Dirt may Drop and Melt into the Goo...

This worked with my Grande Lava Lamp...

Thank You very much for the infomation on this Lava Lamp!!!

Erin said:

They are not white bits, they look like dust. They are not in the lava, they are floating freely in the liquid. And yes, I do find myself focusing more on those than anything else Art!

 

I'm giving it a few more runs, then I'll ask for another or return it. Very disappointing. I really think you should open up a new lava lamp and be delighted. Opening this one up was disappointing and has been so the entire first day of ownership. I looked at it this morning, then glanced over at my beautiful 90s Century...there's just no comparison. *sigh*

 

I have a lot of other thoughts I'd like to post at this time, but I'm going to give this lamp a few more days. Sadly, I feel these problems won't go away. I intend to post on LL's Facebook page, but for once, I'd like to have an OPEN and PUBLIC conversation instead of them just posting "please contact us at blah blah". I want everyone to know. That being said, I feel bad for the people who work at LL - they just need jobs like we all do. It's not their fault their lamps are sub-par. I don't want to take my frustrations out on them, so I'm going to be careful with my words.

Ok sounds good. I would let it run longer I bet the flow changes some since the wax still needs to break in. Did your fuzzies reduce after it flowed? I would just contact them about it anyway.
No. If anything, I had  MORE fuzzies. They are really distracting.

Dr. WHAT?! said:
Ok sounds good. I would let it run longer I bet the flow changes some since the wax still needs to break in. Did your fuzzies reduce after it flowed? I would just contact them about it anyway.
those flipping fuzzies! I sure hope there isn't any in mine.

Starting up the lamp again for day two. Still partially cloudy and the fuzzies are still present. Shawn, I'm hoping that yours looks better than mine!

 

There's no way I'm keeping this lamp if it doesn't clear up/fuzzies go away. And I'm guessing neither of these problems will resolve themselves. 

Reply to Discussion

RSS

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2019   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service