Oozing Goo - The Lava Lamp Syndicate

Interesting story.

About 10 years ago I purchased a Windsor Consort lamp. The darn thing never worked. The wax would simply not heat up. The lamp has sat all this time, unused.

Well, today I thought to myself, "I bet there's a bad connection causing excessive voltage loss in the lamp". I pulled it apart, and sure enough, one of the wires wasn't soldered to the socket. There was a dab of solder on the socket rivet, but nothing on the wire braids. The wire was simply sitting in the rivet! The lamp probably never worked from day one!

I soldered it up, and now the lamp works like a charm.

The moral of my story? If your vintage lamp doesn't heat the wax, check the wiring. In some of the old lamps (like my Windsor) the wires are soldered to the socket. On others, the wires are attached to the socket with screws. The screws often come loose. Check your old lamps, and I bet you'll find some with loose solder joints, or loose screws.


Views: 131

Reply to This


Mark Goo created this Ning Network.

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2022   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service