Oozing Goo - The Lava Lamp Syndicate

Hello. I'm brand new to this site! I just got a lava lamp and plugged it in waiting for the show! Well, after starting out as a blob on the bottom of the glass, it slowly made its way to the top of the glass and has been sitting there, not moving since. It's been 3 hours. What do you suggest? Should I return it? Thanks!

Views: 383

Reply to This

Replies to This Discussion

I suggest you turn it off. Let it completely cool down and start her up again. Soemtimes they start of tempermental. Let it go thru 5 or 6 heat up./ cool completely down cycles and it should get going.

If that doesn't work, consider returning it.
By the way, what brand is it?
And Welcome to OG and lava lamp fandom.

MG
Hiya! The brand is "Peace" by Creative Motion. Made in China. I will try your suggestion and hopefully it will work! Thanks!!
Give your lamp a good 8 hour run, maybe 2. If it doesn't fix itself then try another one by exchange.

I have 2 Peace motion lamps and have no complaints about them they are great.

Hopefully yours will start working.

I have a pic of my clear/silver Peace motion in my pictures on my page. I tried loading a pic but my browser keeps crashing when I try it.

W_J

Reply to Discussion

RSS

About

Mark Goo created this Ning Network.

Support Oozing Goo

By using the eBay button above, you support OG if you purchase anything. Thanks for thinking of us. Mark Goo

© 2021   Created by Mark Goo.   Powered by

Badges  |  Report an Issue  |  Terms of Service