Oozing Goo - The Lava Lamp Syndicate

Hi All

All of my GU10 Telstars have stuck bulbs, has anyone else had this issue? 

I've tried litrally everything. Sometimes they get stuck stright away, sometimes I can change the bulb once or twice before thet get stuck in the base. 

I've seen a couple of reviews on Amazon saying the same so I guess it happens but all of mine are useless at the moment :(. 

Thanks for any help! 

Views: 139

Reply to This

Replies to This Discussion

The only thing I can imagine is that whenever you turn the lamp on/off there is a small spark at the pins of the bulb and over time it becomes sort of a welded spot. I've had switches do that. I would try lubrication like wd40 spray and stay gel lubricant to fill the gaps or probly better a snubber capacitor (x2 type) to surpress the spark...but dont ask me where to put it, space is probly tight.

Thanks for the replies. These are all less than a year old with the exception of the black/copper, some never had the bulb changed I tried everything but the entire fitting is loose in the base so not enough leverage. Even got other people to try to make sure I wasnt being stupid.

The only solution was to take the entire fitting out of the base. Surprisingly there is nothing holding the fitting so seems like a design oversight. 

Plus, they dont space the legs equally anymore with the new silver ones :-/. Makes the whole thing look wonky.

Overall however, the re-design does look great.

Reply to Discussion



Autumn created this Ning Network.



© 2024   Created by Autumn.   Powered by

Badges  |  Report an Issue  |  Terms of Service